4884 : MIT Kerberos 5 krb425_conv_principal Function Remote Overflow
Printer | http://osvdb.org/4884 | Email This | Edit Vulnerability

Views This Week Views All Time Added to OSVDB Last Modified Modified (since 2008) Percent Complete
3 1112 about 10 years ago about 6 years ago 1 times 90%

Timeline

Disclosure Date
2000-05-16

Description

MIT Kerberos 5 contains a flaw that may allow buffer overflow. The issue is triggered by applications which require legacy Kerberos 4 authentication. It is possible that the flaw may allow an attacker to gain root access on affected machines resulting in a loss of confidentiality, integrity, and/or availability.

Classification

Location: Remote / Network Access
Attack Type: Input Manipulation
Impact: Loss of Integrity
Exploit: Exploit Unknown

Solution

Upgrade to version krb5-1.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

Products

Cygnus
KerbNet
5.0.x
Cygnus Network Security
4.0.x
MIT
Kerberos 4
4.0 patch 10
Kerberos 5
5.0-1.0.x
5.0-1.1.1

References

Credit

  • Jeffrey I. Schiller - jismit.edu -
  • Jim Paris - jimjtan.com -

CVSSv2 Score

CVSSv2 Base Score = 10.0
Source: nvd.nist.gov | Generated: 2003-12-31 | Disagree?

Access_vector_2 Access_complexity_2 Authentication_2 Confidentiality_impact_2 Integrity_impact_2 Availability_impact_2

Comments

No Comments.

The database information may change without any notice. Use of the information constitutes acceptance for use in an AS IS condition, and there are NO warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the copyright holder or distributor (OSVDB or OSF) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.

© Copyright 2002 - 2014 Open Sourced Vulnerability Database (OSVDB), All Rights Reserved.
Privacy Statement - Terms of Use