The vulnerability is caused due to an error in the processing of URLs within the "ngx_http_parse_complex_uri()" function. This can be exploited to cause a buffer underflow via a specially crafted request and may allow execution of arbitrary code.
Loss of Integrity
Upgrade to version 0.7.62, 0.6.39, 0.5.38 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.
The database information may change without any notice. Use of the information constitutes acceptance for use in an AS IS condition, and there are NO
warranties, implied or otherwise, with regard to this information or its use. Any use of this information is at the user's risk. In no event shall the copyright
holder or distributor (OSVDB or OSF) be held liable for any damages whatsoever arising out of or in connection with the use or spread of this information.